Finally Got The Car Smogged, But... - Nissan : Datsun ZCar forum :Nissan Z Forum: 240Z to 370Z
User Tag List

 
LinkBack Thread Tools
post #1 of 4 (permalink) Old 10-04-2016, 03:27 AM Thread Starter
Senior Member
 
TheBob's Avatar
 
Join Date: Nov 2012
Location: California 1981 280ZXT
Posts: 615
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 47 Post(s)
Garage
(Thread Starter)
Finally Got The Car Smogged, But...

My '81 ZX T would not smog this year. So after about $750, including 2 new injectors, all new insulators, sensor adjustments, running down vacuum leaks, a little scullduggery and labor, it finally eked through the test.

However, the car would stall intermittently. It could happen at idle or at highway speeds at any moment, but then would fire right back up and continue. I was puzzled.

I searched this Forum and the results confirmed my thoughts: fuel pump/fuel filter/coil/ignitor/ignition module were the probable cause of my problem, either one of these or a combination of them.

In the meantime, my mechanic had mentioned that it appeared the Air Regulator (a replacement to an original I deftly broke) was not working properly, nor was the Vacuum Control Modulator. So I tracked down replacements for each and installed them.

The car immediately started performing as it used to on cold starts and there have been no intermittent stalls since I made the change! I have driven it quite a bit expecting a sudden crap-out, but, happily, I have been denied.

Now I don't know which of the components was responsible for the stalls - I am thinking VCM - but you might want to add that to the list of fuel pump, fuel filter, etc....
Attached Images
File Type: jpg 3484.jpg (230.7 KB, 1 views)
TheBob is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 04-01-2017, 06:08 PM
Junior Member
 
Chuck1979zx's Avatar
 
Join Date: Mar 2017
Posts: 25
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Quote:
Originally Posted by TheBob View Post
My '81 ZX T would not smog this year. So after about $750, including 2 new injectors, all new insulators, sensor adjustments, running down vacuum leaks, a little scullduggery and labor, it finally eked through the test.

However, the car would stall intermittently. It could happen at idle or at highway speeds at any moment, but then would fire right back up and continue. I was puzzled.

I searched this Forum and the results confirmed my thoughts: fuel pump/fuel filter/coil/ignitor/ignition module were the probable cause of my problem, either one of these or a combination of them.

In the meantime, my mechanic had mentioned that it appeared the Air Regulator (a replacement to an original I deftly broke) was not working properly, nor was the Vacuum Control Modulator. So I tracked down replacements for each and installed them.

The car immediately started performing as it used to on cold starts and there have been no intermittent stalls since I made the change! I have driven it quite a bit expecting a sudden crap-out, but, happily, I have been denied.

Now I don't know which of the components was responsible for the stalls - I am thinking VCM - but you might want to add that to the list of fuel pump, fuel filter, etc....
My car didn't pass the emissions test and while I was having it fixed I found out about Historic Car insurance and bought it. Now my 1979ZX is exempt from emissions.
Chuck1979zx is offline  
post #3 of 4 (permalink) Old 04-20-2017, 11:45 PM Thread Starter
Senior Member
 
TheBob's Avatar
 
Join Date: Nov 2012
Location: California 1981 280ZXT
Posts: 615
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 47 Post(s)
Garage
(Thread Starter)
Very nice. Now if it will only work in CA...(I doubt it. This state is under the control of idiot socialists right now...)
TheBob is offline  
 
post #4 of 4 (permalink) Old 04-23-2017, 09:24 PM
Junior Member
 
Join Date: Apr 2017
Location: Davis, CA
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Quote:
Originally Posted by Chuck1979zx View Post
My car didn't pass the emissions test and while I was having it fixed I found out about Historic Car insurance and bought it. Now my 1979ZX is exempt from emissions.
Where did you find your vcm valve at? I have a 280zxt and I'm looking for a new OEM value and cannot find?
JSCHAAP is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Nissan : Datsun ZCar forum :Nissan Z Forum: 240Z to 370Z forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



  Similar Threads
Thread Thread Starter Forum Replies Last Post
De-smogged, now what?? DaFlash 70-83 Tech Discussion Forum 3 07-04-2006 08:50 PM
anyway to get an rb20det swap smogged CA?? 24ounce 84-89 Tech Discussion Forum 3 10-05-2005 02:43 PM
how do i go about getting an rb20det swap smogged CA or am i screwed? 24ounce 70-83 Tech Discussion Forum 12 10-05-2005 01:30 AM
Just got smogged.... acesfullof10s 90-96 Tech Discussion Forum 8 09-17-2005 10:10 PM
CA Smogged 280Z vs non-smogged Unknown User 70-83 Tech Discussion Forum 4 01-12-1999 08:49 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 


Content Relevant URLs by vBSEO 3.6.1